GDM going to sleep

Bonjour,

After installing a NUC with Debian GNU/Linux buster, it goes to sleep because GDM says so after 20 minutes or so.

# sudo -u Debian-gdm dbus-launch gsettings list-recursively org.gnome.settings-daemon.plugins.power
org.gnome.settings-daemon.plugins.power power-button-action 'suspend'
org.gnome.settings-daemon.plugins.power idle-dim true
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 1200
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 1200
org.gnome.settings-daemon.plugins.power ambient-enabled true
org.gnome.settings-daemon.plugins.power idle-brightness 30

It was not strictly necessary for this machine to have a graphical interface but I thought it could be handy. It turns out that there is no convenient way to ask GDM to never go to sleep. So Iā€™m trying this as a workaround:

# sudo -u Debian-gdm dbus-launch gsettings range org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type
enum
'blank'
'suspend'
'shutdown'
'hibernate'
'interactive'
'nothing'
'logout'
# sudo -u Debian-gdm dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing

To be continued in 20 minutes :stuck_out_tongue:

It went to sleep anyways. Trying to set a really long timeout:

sudo -u Debian-gdm dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 400000000

It went to sleep anyways. Trying without GDM

systemctl stop gdm

That works :slight_smile:

@loic,

Which NUC model did you use ? I would like to have one too.

The nuc5cpyh.

1 Like